Workflow Outage

Incident Report for Unlimited Financials UNO

Resolved

This incident has been resolved.
Posted Oct 17, 2024 - 19:24 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2024 - 19:07 EDT

Identified

While we investigate this issue, the work around is to use the Print Claim option to generate another attachment and print onto a blank HCFA form.
Posted Oct 17, 2024 - 16:15 EDT

Investigating

We are currently aware of an issue impacting paper claims. Our team is investigating the source and scope of the problem in pursuit of resolution.
Posted Oct 17, 2024 - 16:13 EDT
This incident affected: UNO Environment.